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Introduction
Welcome to the Command Ops (CO) MapMaker. The MapMaker is used to create and modify 
CO maps. You can also use it to access data about the movement and visibility effects of the different
map objects. These are summarized though in the Terrain Effects Chart at Annex E of the Game 
Manual.

It is a standard Windows type application with a menu bar at the top. This includes the standard File 
menu that allows you to open, close, create new maps, save and save as existing maps.

This manual is organised along functional lines and in a sequence that most users will employ when 
creating a map. If you want to know how to do a specific thing, look up the table of contents.

Please  note  that  this  manual  uses  screenshots  from  the  original Airborne Assault:Conquest  of  the 
Aegean MapMaker. While the name has changed and in some places there are a few cosmetic changes, 
the details depicted remain the same. Where there has been a material change, then new graphics have 
been substituted.

What’s in this Manual

This manual is organised in two parts – the Basics and the Guide. The Basics provides an overview of 
the user interface. The Guide walks you through the steps for creating and modifying maps. It starts 
with creating a new map completely from scratch; if you want to start by editing an existing map, just 
jump in at that section. If you want to know how to do a specific thing, look up the table of contents. 
Annex A provides a sequence of steps for designing a map.

What Makes a Map

A Map is made up of two main types of data:

Map Objects – These are the different areas and lines used to represent the different terrain features 
such as woods, towns, roads and rivers. Map Objects are arranged in layers, being drawn one on top 
of the other. Altitude layers (representing the height of the ground) are drawn first, then the different 
terrain areas are drawn (as pattern filled polygons) and finally the roads and other line features.

Map Effects – These control the Visibility and Movement rates specific to your map. Each layer has 
its own effects.

What’s New
You can now cut and paste objects between layers of the same type - ie from one line layer to another 
line layer or from one area layer to another area layer or from one altitude layer to another altitude 
layer. Simply copy the object ( Control-C ), then select the new layer from the layers list and paste ( 
Control-V ) See  Move Area / Line Object to Different Layer.
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The Basics
Getting Started

Launch MapMaker

To launch the MapMaker application:

 Select the MapMaker program from the game launcher menu

 Double-click the MapMaker application icon in the game directory

Open Map

To open a map file:

 Select Open from the File menu ( Ctrl + O ) or

 Click on the Open button of the toolbar

This will open the Open window displaying a list of map files within the Map 
directory, which is part of the Game directory.

 Select the desired map file from the list

 Click on the Open button
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Save Map

To save a map file under the same name:

 Select Save from the File menu ( Ctrl + S ) or

 Click on the Save button of the toolbar

To save a map file under a different name:

 Select Save As… from the File menu

This will open the Save As window displaying a list of map 
files within the Map directory.

 Enter the desired name

 Click on the Save button

Note  avoid  saving  over  the  top  of  one 
of the original maps provided. It is 
recommended that after opening one of 
these,  you  do  a  Save As  and  give  it  a 
different name before modifying it.

Close Map

To close a map file:

 Select Close from the File menu or

 Click on the Close Box at the top right of the map 
window
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The User Interface – A Quick Tour
With a map file open, the main screen displays a map window, a layer list in the sidebar on the left and 
a toolbar underneath the menus at the top.

Map Window

The map window behaves like a normal Windows window. It has the standard Minimize, Maximize 
and Close buttons at the top right and can be resized by grabbing an edge or a corner and dragging it. 
It can be repositioned by grabbing the title bar and dragging it. Multiple map windows can be open at 
once and these can be cascaded and tiled using the items of the Window menu.

The map window displays the various areas and lines which make up the map. These can be selected 
using the Selection or Arrow tool. It uses the graphics from the Map Pattern files located in the Game/
Graphics\Map\Default directory to draw and fill the map objects. These can be changed – see Set Map 
Patterns.
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Scroll

To scroll the map:

 Use the horizontal and vertical scroll bars or

 Select the Grabber tool  and click the left mouse button and drag or

 While  holding  the  Space key down, left-click and drag the map
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Zoom In and Out

The map can be viewed at a number of scales ranging from 2m per pixel to 64m per pixel.

To zoom in on the map:

 Choose Zoom In from the View menu, or

 Press the Ctrl + Page Down keys, or

 Select the Zoomer tool  and left click on the map or

 Scroll the mouse scroll wheel towards you

To zoom out on the map:
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 Choose Zoom Out from the View menu, or

 Press the Ctrl + Page Up keys, or

 Select the Zoomer tool  and Ctrl-click on the map or

 Scroll the mouse scroll wheel away from you

To display the map at a particular zoom level or desired scale:

 Choose the desired scale (e.g. 64 Meters Per Pixel ) from the View 
menu, or

 Use the keyboard shortcuts –  Ctrl + 1 to Ctrl + 6

Grid

To show / hide a 1km grid:

 Select Show Grid from the View menu, or

 Press  Ctrl + G keys 

The light grey lines are every 1km. The dark grey lines every 10km.
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Show / Hide Layers

To display all layer types:

 Choose Display All Layers on the View menu or press Ctrl + E keys

To turn off all layer types:

 Choose Hide All Layers on the View menu or press Ctrl + H keys 

Note that the Underlay Bitmap will still be drawn if it is currently being displayed.

To show / hide individual layers or groups of layer:

 Check or uncheck the check boxes in the Layer List on the Sidebar.

Note that when you check/uncheck a group all layers within that group are 
automatically checked/unchecked and shown/hidden.
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Toolbar

Located below the menu bar, the toolbar consist of four buttons as follows:

New – Create a new Map

Open – Open an existing map

Save – Save the Map

About – Display the About Box

To show/hide the Toolbar:

 Select Toolbar from the View menu

When the Toolbar is displayed there will be a tick next to the menu item.

Tools

Located below the menu bar, the tools consist of five buttons as follows:

Arrow – Select objects on the Map, Areas, Lines, Text

Draw – Draw Area and Line points and to add new Text items

Trace – Rapidly draw multiple points 

Zoomer – Zoom In, Zoom Out (when holding Ctrl key down) the Map

Grabber – Grab the map and scroll around

To show/hide the Tools:

 Select Tools from the View menu

When the Tools are displayed there will be a tick next to the menu item.

Layer List

The Layer List occupies the sidebar on the left. It is a tree list with an entry for each terrain layer type. 
Each entry is identified by an icon and name. To the left is a checkbox used to show/hide objects of 
that type on the map – see Show/Hide Layers. The entries are grouped – eg roads, vegetation, ground, 
altitude. To the left of each Group name is a +/- box used to expand/collapse the tree node.
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To access the data for a given layer:

 Double-click the layer in the list

This opens the Layer Data window where 
you  can  edit  the  various  hit,  move  and 
visibility effects – see Layer Effects.

To show/hide the Layer List:

 Select Layers from the View menu

When the Layer List is displayed there will be a tick next to the menu 
item.

Menus

The menu bar is at the top of the window and consists of the following menus.

File

Provides standard Windows application File menu features – New, Open, Close, Save, 
Save As, recent files and Exit.

Edit

Undo ( Ctrl + Z ) – Supports multi level undo

Redo ( Ctrl + Y ) – Supports multi level redo

Delete ( Del ) – Delete the currently selected object

Duplicate – make a copy of the current selected objects

Select All ( Ctrl + A ) – Select all objects of the current layer

Deselect All ( Ctrl + D ) – Deselect all currently selected objects

Multi-Layer Select – Select the object directly under the cursor no matter what layer it belongs to.
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Draw

Corner Points – Points added to Lines / Areas will be corner points, produces straight 
Lines and Area borders

Control Points – Points added to Lines / Areas will be control points, point acts as a 
Bezier control point producing a curved Line or Area border

Toggle Point Type ( Ctrl + T ) – Toggle the type of the currently selected point between Corner and 
Control

Join Lines – Join two selected lines

Split Line / Area  – Select a non end point of a line / area and use it to break the line / area in half. 
Warning: Areas cannot be joined

Simplify Lines / Areas  – Remove points of a Line / Area in an attempt to reduce their complexity, 
tends to straighten Lines and Area borders. This can help make map drawing faster when there is no 
cache available.

Map

Map Name – see Set Map Name

Map Data ( Ctrl + R )– used to resize and reposition the map size and 
to change the metres per altitude – see Create New Map

Map Effects ( Ctrl + M ) – see Generic Effects

Import Map – see Join Two Existing Maps.

Import Map Effects – see Import Map Effects.

Layer Data ( Ctrl + L ) – Edit current Layer’s Movement and Visibility 
Effects – see Layer Effects

Line Embankment – see Embankments

Calculate Terrain Tables – see Calculate Terrain Tables

Generate Map Draw Cache – See Generate Map Cache

Show Movement Tables – see Check Terrain Data

Show Height Map – see Spot Heights

Bitmap Underlay ( Ctrl + U ) – see Use Bitmap Underlays

Bitmaps Across – How many files in the Underlay, 1, 4, or 16 – see Use Bitmap Underlays
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View

This  menu  contains  items  to  zoom  the  map,  show/hide  layers,  map  grid,  and  the 
various interface elements ( toolbar, tools etc ).

Zoom In ( Ctrl + Page Down ) – see Zoom In and Out.

Zoom Out ( Ctrl + Page Up ) – see Zoom In and Out.

Display All Layers ( Ctrl + E ) – see Show / Hide Layers.

Hide All Layers ( Ctrl + H ) – see Show / Hide Layers.

Show Grid ( Ctrl + G ) – see Grid.

64 Meters Per Pixel ( Ctrl + 1 ) – see Zoom In and Out.

32 Meters Per Pixel ( Ctrl + 2 ) – see Zoom In and Out.

16 Meters Per Pixel ( Ctrl + 3 )  – see Zoom In and Out.

8 Meters Per Pixel ( Ctrl + 4 ) – see Zoom In and Out.

4 Meters Per Pixel  ( Ctrl + 5 )  – see Zoom In and Out.

2 Meters Per Pixel ( Ctrl + 6 )  – see Zoom In and Out.

Toolbar – Show / Hide – see Toolbar.

Status Bar – Show / Hide the status bar at the bottom of the map.

Tools – Show / Hide – see Tools.

Layers – Show / Hide – see Show / Hide Layers.

Window

Provides standard Window menu features

Help

Shows the About box.
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The Guide
Create New Map

 There are a number of ways to create a new map:

 Start from Scratch

 Crop an existing map

 Extend an existing map

 Join two existing maps.

Starting from scratch is hard work. You will have to create each and every map object from scratch. It’s 
easier to modify an existing map by cropping it, extending it or joining it up with another map.

Start from Scratch

 Select New ( Ctrl + N ) from the File menu

Alternately,

 Press the New button on the tool bar

This opens the New Scenario dialog.

 Set the map width and height

Note that this will be rounded to the nearest 64 metres. Please 
do not create a map bigger than 2000 square kilometres (40 x 
50). The larger the map, the more time required to determine 
routes and hence the slower the game play.

 Set the Base Altitude

The default is zero – ie sea level. Only change this if you 
need to. See the discussion below. 

 Set the metres per Altitude Layer
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Altitude layers equate to contour intervals drawn on a topographic map. So in effect you are setting the 
contour interval being used for the map. The default is 10m. The value can be set between 1 and 200 
metres. Remember that you only have 15 Altitude layers, plus the 0m base, to play with. Thus setting 
the value to 10 with a base altitude of 0 provides you with the following altitude layers:

0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100, 110, 120, 130, 140 and 150 meters.

If you want to ascend higher than 150 meters you have three options. First you can set the base altitude 
higher ( eg setting it to 100 would allow you to reach 250m ). Second you can set the metres per 
altitude layer higher ( eg at 20m per layer you can cover from 0 to 300m ). Thirdly you can set both 
the base altitude and the metres per altitude layer higher ( eg base = 250 and metres per alt layer = 50 
would allow you to cover from 250 to 1000 ).

 Select the OK button.

The screen should now look like this, with a new map window.

The new map 
is perfectly flat, 
like a billiard 
table  -  a  fresh 
canvas, for 
you, the map 
maker.

 Save the new map – see Save Map.

 Save early, save often!
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Crop an Existing Map

If you want to make a smaller scenario focussing on just one particular area of an existing scenario, 
you can create the map for it by cropping the original larger map.

To crop an existing map:

 Open the existing map – see Open Map.

 Turn the map grid on - see Grid.

 Select Map Data from the Map menu or press Ctrl + R

This opens the Map Data dialog, which will display the current map width and height.
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To resize the map:

 Enter the desired Map Width and Height

Note the size will be rounded to the nearest 64 metres.

To reposition the map objects:

 Enter the desired X, Y offsets in metres

Note that in 
the adjacent 
example we 
are resizing 
the  map  to  be 
10 x 20km 
(rounded to the 
nearest 64m) 
and we are 
repositioning 
all the objects 10km to the left and 10km up. This will 
in effect make the top left of the map 10km right or east 
of where it is now and 10km down or south of where it 
is now.

 Press the OK button to save and close the dialog

A warning message 
dialog will ask you 
to confirm.

 Press Yes to confirm.

The map should now be cropped.

 Save the map under a new name – see Save Map.

 WARNING – Ensure you choose Save As rather than Save, or you will 
overwrite the original map.

After modifying the map it is very important to recalculate the terrain tables and if 
required to regenerate the map cache ( this draws the map faster in the game ).

 Recalculate Terrain Tables – see Prepare Map for Use
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 Regenerate the map cache – see Generate Map Cache

 Save the map 

Extend Existing Map

To extend an existing map:

 Open the existing map

 Determine the desired extra map width and height

Eg. if you want to add 5km to the top and another 3km to the 
bottom, then the extra map height would be 8000.

 Select Map Data  from the Map menu or press 
Ctrl + R

 Note down the original map width and height

 Determine the new map width and height

Ie. new height = original height + extra height

 Enter the new Map Width and Height

 Enter the desired X and Y offsets in metres

In the above example we have taken the Platamon map and added 8000m to the height. We are going 
to reposition the map objects by 3000m from the top. This will effectively add 3km to the top and 5km 
to the bottom.

 Press OK 

A warning message dialog will ask you to confirm.

 Press Yes to confirm

The map should now be extended.
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 Save the map under a new name – see Save Map. 

 WARNING – Ensure you choose Save As rather than Save, or you 
will overwrite the original map.

After modifying the map it is very important to recalculate the terrain tables 
and if required to regenerate the map cache (this makes drawing the map faster 
in the game).

 Recalculate Terrain Tables – see Prepare Map for Use

 Regenerate the map cache – see Generate Map Cache

 Save the map 

Join Two Existing Maps (Import Map)

This can be useful where you have an existing map 
and have created a separate map for an adjoining 
area and you now want a single combined map. For 
example, let’s say you want to create a map that 
follows the road from Veve to Ptolamais inclusive. 
You would need to join the Kleidi Pass map with 
the Amyntaion map. 

 WARNING  –  don’t  join  maps  that  have  a 
different metres per altitude layer 

They can have a different Base Altitude, however 
any resulting excess altitude layers will be lost - 
see below.

 In some cases it may be best to crop each 
map before joining, in other cases this can 
be done after joining.

In our example, we will first crop the wider Kleidi 
Pass map as indicated.

 Crop maps as required – see Crop 
Existing Map.
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Note the new cropped section is the same width as the Amyntaion map and aligned such that it will fit 
directly on top of it. Now it’s time to join them together.

To join two maps:

 Open both maps

 It is essential that both be opened.

 Note the map height and width of the map to be imported

 Resize the “destination” map so it will be big enough for the imported map to fit into it – see 
Extend Existing Map
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In our example we will extend the existing Amyntaion map.

 Select Import Map from the Map menu

This opens the Select File to import window, which displays a list of 
opened files.

 Select the desired file

 Enter the top left offset

Note in our example the imported map needs no offset as it is to be 
positioned at the top.

If the base altitudes of the maps are different then:
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 Set the imported map’s Base Layer to the 
matching  altitude  layer  of  the  destination 
map. 

In our example they are the same, so this field is 
left at the default setting – ie “Base”. For details 
on what to do when they are different see Set Base 
Layer To.

 Press the OK button

Hey presto – the maps are combined. You may need to spend some time editing the map objects along 
the join to ensure they are aligned correctly.

 Edit map objects along join ( if required ). See Draw Map
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 Save the map under a new name – see Save Map.

 WARNING  – Ensure  you  choose Save As   rather  than Save,  or  you  will  overwrite  the 
original map.

After  modifying  the  map  it  is very  important  to  recalculate  the  terrain  tables  and  if  required  to 
regenerate the map cache (this makes drawing the map faster in the game).

 Recalculate Terrain Tables – see Prepare Map for Use

 Regenerate the map cache – see Generate Map Cache

 Save the map 

Set Base Layer To

When the base altitudes are different you need to set the imported map’s Base Layer to the matching 
altitude layer of the destination map.

 Note that where base altitudes are different 
import the map with the higher value.

 This may result in loss of data.

Eg. If the metres per altitude layers is 10m and the 
base alt of the imported map is 50m while that of 
the destination map is 0m, you will need to set the 
“Base Layer To” field to “Alt 5”. This will in effect 
add the Alt 0 layer of the imported map into the Alt 
5 layer of the destination map; Alt 1 to Alt 6 and so 
on. Because there are only 16 altitude layers ( Alt 0 
to Alt 15 ) the last five layers of the imported map 
will not be imported.

Set Map Name

When a scenario is listed in the Scenario Selection window of the Game, it is prefixed with a map 
name. In this way scenarios are grouped according to their map. To specify the map name used in the 
Scenario Selection window:

 Select Map Name from the Map menu
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 Enter the name

 Press OK

 Save the map 

Note that if this is left blank, the Map file name will be used. By convention 
all cropped maps should bear the name of the map from which they were 
cropped.

Set Map Effects
The Map file contains various effects. Some are generic and some are specific to each Map layer. 
Probably the easiest way to set the effects is to import them from another map. Otherwise you need to 
set them from scratch.

Import Map Effects

To import the map effects from one map to another:

 Open both maps

 It is essential that both be opened.

 Select Import Map Effects… from the Map menu

This will open the Select Map Data To Import window.

 Select the desired map from the list

 Press OK.

After  modifying  the  map  it  is very  important 
to recalculate the terrain tables and if required to 
regenerate the map cache (this makes drawing the 
map faster in the game).

 Recalculate Terrain Tables – see Prepare 
Map for Use
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 Regenerate the map cache – see Generate Map Cache

 Save the map 

Generic Effects

To set the Generic map effects:

 Choose Map  Effects from  the Map  menu  or 
press Ctrl + M

This dialog controls the non-terrain specific Movement and 
Visibility effects. Each figure represents a percentage value 
from 0% to 100%.

 Enter the respective values

Default Movement Effects – The percentage modifiers 
applying to the normal movement speed of motorized and 
non-motorised  units  in  open  terrain  –  ie  where  no  other 
terrain is present.

Visibility Weather Modifiers – Reduces the maximum visibility distance that a unit can be sighted 
from based on the current in game weather.

Visibility Night Modifiers  – Reduces the maximum visibility distance that a unit can be sighted 
from based on the time of day.

By default the maximum visibility is 10,000 metres. In heavy rain this would be reduced to 8,500m 
during daylight (10,000 x 0.85) and to 6375m if it were still raining at dusk (10,000 x 0.85 x 0.75).

 Click OK to save the new effects settings.

After  modifying  the  map  it  is very  important  to  recalculate  the  terrain  tables  and  if  required  to 
regenerate the map cache (this makes drawing the map faster in the game).

 Recalculate Terrain Tables – see Prepare Map for Use

 Regenerate the map cache – see Generate Map Cache

 Save the map 
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Layer Effects

To set the effects specific to each map layer:

 Select the desired layer from the Layer List in the Sidebar and then select Layer Data from 
the Map menu or press Ctrl + L or

 Double-click the desired layer from the Layer List in the Sidebar

The Layer Data window should open.

 The Text and Altitude layers cannot be edited

 Edit the desired fields

Name – You can change the name of the Layer. This appears 
in the game on the Unit Info display of a selected unit.

Height – This is the hight in metres of the feature above the 
normal ground level. When calculating line of sight (LOS) 
the height at any spot on the map depends on the underlying 
Altitude layer plus the height of any terrain feature such as 
tall trees or buildings. So for LOS purposes height = altitude height + object height. Eg. For a city on 
an altitude layer of 50m, the LOS height would be 64m (50 + 14).

Hit Effect – This modifies the probability of taking casualties when fired upon. Values are a percentage 
of the standard hit probability; they do not have to be less than 100%, e.g. by default woods have an 
Area hit effect of 115%, i.e. it is worse to be caught in woods by artillery than in the open (due to air 
bursts on branches)! Note these are cumulative with other modifiers such as unit effectiveness etc.

Movement Effect  – The percentage of a unit’s normal movement speed that it can move in this 
terrain. This overrides the figure entered in the Map Effects dialog but it is cumulative with any effects 
for Dyke.

Visibility Reduction Per 100m – This is the amount that visibility is reduced for every 100 meters. 
Visibility starts at 100%, so a reduction amount of 20% has the following affect on visibility:

Reduction amounts can be specified for Personnel (Non-Motorized units), 
Vehicles  (Motorized  units)  and  Guns  /  Rocket  launches  (Artillery  units). 
They can also be different depending on whether the unit to be spotted is 
Deployed, Moving or Firing.

 Press OK

After modifying the map it is very important  to recalculate the terrain 
tables and if required to regenerate the map cache (this makes drawing the 

Distance Visibility

0 100%

100 80%

200 60%

300 40%

400 20%

500
Not 
Visible
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map faster in the game).

 Recalculate Terrain Tables – see Prepare Map for Use

 Regenerate the map cache – see Generate Map Cache

 Save the map 

Set Map Patterns
How the map actually looks when it is displayed is determined by the colours and 
patterns stored in the map pattern files. There are three - MapPat.bmp, MapPatA.
bmp and MapKey.bmp. The first file, MapPat.bmp defines the patterns to be drawn 
for each layer at each zoom level. The MapPatA.bmp file indicates how transparent 
different areas on each graphic should be. White areas in the MapPatA.bmp file 
indicate completely opaque areas, black areas indicate complete transparency, and 
shades of grey indicate partially transparent areas. The MapKey.bmp file contains 
the graphics displayed in the MapMaker terrain key list and in the Terrain popup 
used in the Game.

Modify Map Patterns

You  can  edit  these  with  no  special  tools;  Microsoft  Paint®  is  sufficient.  It  is  a 
good  idea  to  create  a  backup  of  your  original  map  graphics  files  before  making 
modifications, so you can easily go back to the defaults if you want.

Changing the map graphics will have no negative effect on online play.

To modify the graphics used to display different terrain types:

 Copy the Command Ops 2/Graphics/Map/Default directory

 Rename it – eg My Map Graphics

 Open  the  MapPat.bmp,  MapPatA.bmp  and  MapKey.bmp  files,  located 
within the new directory, in your favourite paint program

 Modify them to your hearts content

 Save them
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Use New Map Patterns

 Open the desired 
map(s)  in  the  MapMaker 
application

 Select Map Data from the 
Map menu

 Select the Browse button 
at the bottom of the Map 
Data dialog

 Navigate to and select 
your new directory

 Click OK

 Save the map
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Draw Map

Use Bitmap Underlays

There are two ways you can approach drawing a Map, freehand (using your imagination) or using a 
scanned image of an existing (source) map displayed in the MapMaker as a “Bitmap Underlay”.

When the “Bitmap Underlay” option is activated it will draw the bitmap image of your source map 
under all the other layers of the map. It is much easier to create your map by tracing over an existing 
source map image than it is to create a realistic map with no guidance.

To use an underlay:

 Scan your source map

You can do this manually yourself using one of the relatively inexpensive desktop scanners.  Scan at 
a resolution of 300dpi. This prints well and provides enough detail. Alternatively, you can purchase 
scanned images of archival maps from most reference map libraries. We sourced our scans for Greece, 
Crete and Malta from the Australian National Library. Their map library provided the 300 dpi scans 
on CD.

 Crop, rotate and enhance it till you have an image representing the area you intend to map

 IMPORTANT – Crop your map to the actual size of your map in meters. E.g. if the map height 
and width are 10,000 x 8,000m, make sure that the bitmap underlay is of an area measuring 
10,000 x 8,000m

Remember that the MapMaker rounds Maps to the nearest 64 meters. It does not matter how big your 
bitmap is in pixels, as the MapMaker will scale it to cover the whole of the map’s area. However, 
having said that, the higher the resolution of the bitmap underlay the more accurate your tracing can 
be. For the preparation of the original maps used in the Game we scanned the maps at 300 dpi and then 
scaled them so that each pixel represented 4m.

 Save your image as a Windows Bitmap (*.bmp) file. It must be named MapScan 0.bmp

Note the space between MapScan and the 0.

 If necessary, create a folder called MapScans at the root level of your Game folder

 Place the MapScan 0.bmp file in the MapScans folder

If your Bitmap file is large you may find the drawing performance in the MapMaker suffers. To increase 
performance:
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 Break up the original scan into four or 16 smaller bitmap files

The options are to break the image into 
1, 4 or 16 Bitmap files. The names of 
these files must be MapScan 0.bmp, 
MapScan 1.bmp etc. The numbering 
starts in the top left hand corner of the 
map  and  works  its  way  across  then 
down.

One Bitmap File: 

0

Four Bitmap Files:

0 1

2 3

Sixteen Bitmap Files:

0 1 2 3

4 5 6 7

8 9 10 11

12 13 14 15

 Some  image-editing  programs 
contain  tools  to  automatically 
slice  an  image  into  a  number 
of sections and save each section separately

 Jasc®  Paint  Shop  Pro®  and Adobe®  Photoshop®  are 
two such programs

 Photoshop  will  require  you  to  use  additional  tools  to 
convert and rename the files it generates since it will not 
save sliced images in bitmap format

Once your Bitmap file(s) are created and in place:

 Set the desired Bitmaps Across (ie 1, 4 or 16)
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 Ensure the map is set to a resolution other than 64 metres per pixel – see Zoom In and Out. 

The Bitmap Underlay menu item is only enabled at higher resolutions ( ie 2, 4, 8, 16, or 32 metres per 
pixel ).

 Select Bitmap Underlay from the Map menu or press Ctrl + U to toggle the display of the 
Underlay Bitmap.

If your bitmaps have been correctly set up the image of your underlay will now appear. If the map 
remains blank, then check you Folder and File names and ensure the map scale is not set to 64 metres 
per pixel.

Note  that  to  speed  up  drawing  while  using  the  bitmap  underlay,  the  map  objects  are  drawn  using 
non-textured patterns. So the map will look little different while drawing. However, once the bitmap 
underlay is turned off they will return to the normal textures. This has no effect on the textures used 
in the Game.

You are now ready to start drawing your map.
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To view just the underlay:

 Select Hide All Layers ( Ctrl +  H ) from the View menu.

To turn all the layers back on again:

 Select Display All Layers ( Ctrl +  E ) from the View menu.
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Area and Line Layers

There  are  two  types  of  layer,  Area  layers 
which are drawn as polygons and Line 
layers which are drawn as, well, lines.

Layer Notes:

 The 0 Altitude layer cannot be drawn, 
it is the base layer of the map and 
always covers the whole map

 Altitude  layers  are  drawn  under  all 
other layers, higher altitudes on top

 The height at any location is 
determined using the highest altitude 
at that location

A Spot Heights algorithm is used to 
determine the exact height at a location. Eg a 
location lying roughly midway between the 
edges  of  two  altitude  layers  (  40  and  50m 
)  will have a  spot  height midway between 
them ( 45m ).

 Altitude layers are always drawn as a solid pattern

 Other Area layers are drawn using transparent patterns

Area / Line Object Notes:

 Both types of objects are created as a series of points

 These points can be either Corner Points or Control Points

 Use Corner Points for drawing areas and lines with straight edges

 Use Control Points for drawing areas and lines with smooth edges or curves

Area Layers Line Layers

Fort Ferry

Industrial Heavy Road Bridge

Factory Medium Road Bridge

Village Light Road Bridge

Town Highway

City Road

Orchard Minor Road

Rough Track

Woods Rail Bridge

Light Woods Rail

Major River Dike

Lake Stream

Beach Minor Stream

Airfield

Marsh

Broken

Impassable

Altitude Layers



37

 Corner Points are displayed 
as Squares and result in straight 
lines and edges
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 Control Points are displayed as Circles and 
result in curved lines and edges

 Control  Points  require  more  memory  and 
disk space than Corner Points

Note that Corner points are always on the line or edge. 
Control  points,  however,  can  be  offset  from  the  line 
or edge. They behave as Beziers. Pulling them in one 
direction will accentuate the curve, while pushing them 
the other way will flatten it.
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Draw Area / Line Objects

To select the type of object to draw:

 Click on its layer in the Sidebar

In our example the Factory layer has been selected. Any drawing 
will draw a new Factory area object.

To set the type of points to draw (Corner or Control):

Choose Corner  Points  or Control 
Points  from  the  Draw  menu.  The  default  is 
Corner Points

Select  one  of  the  two  drawing  tools  –  ie 
Draw  or Trace 

The standard Draw tool adds one more point each time you click on the map. The Trace tool continues 
to place points as you drag over the map. Hence the trace tool is useful for freehand drawing or tracing 
of lines and areas of the bitmap underlay.

 Click (or click and drag) until all the points needed 
for the object have been added

Note that after you place the third point of 
an  area  object,  it  automatically  links  the 
start point to the current point as indicated.
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 You  can  hold  down  the  Alt  key 

while clicking to insert a 
point of the opposite type to the 
one selected in the Draw menu

Eg  if  you  are  currently  drawing  Corner 
points, holding down the Alt key will add 
a Control point.

 Press the Enter key (on the 
numeric  key  pad)  key  and  the  new  object  will  be 
deselected and drawn as it will appear in the Game and 
ScenMaker

 Repeat for each object to be added to the map

Modify Individual Points

 Select the Area / Line object to be modified

Note to quickly change from the Draw or Trace tool to the Arrow tool:

 Hold Down the Ctrl key

 Click on the Point to be modified (it will be displayed as either a hollow square or circle).

To delete it:

 Press the Backspace or Delete keys    or the Del key  
(on the numeric keypad) 

To change it’s type:

 Press Ctrl + T keys +  

To move it:
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 Drag the point, or

 Press the Up, Down, Left or Right Arrow keys     
(on the numeric keypad) to move the selected 
point North, South, West or East a small 
distance or

 Press  the  Home,  Page  Up,  End  or  Page  Down  keys    

  (on the numeric keypad) to move the selected 
point Northwest, Northeast, Southwest, or Southeast a small distance

Navigate Points

To navigate around the points in an object:

 Select a point

 Press the Left Arrow key  to select the previous point, or

 Press the Right Arrow key  to select the next point

Split Lines / Areas

To split a line or Area object:

 Select the point where you want to split

 Select Split Line / Area from the Draw menu

Note that you now have two polygons or lines. Each line segment or polygon 
will have a point located at the original point – ie there will now be two points 
there, one for each segment.

 Select the original point and drag a little

 Press the Enter key to update the display
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Note also that in some cases you may end up with a polygon of less than three 
points or a line of only one point. In which case, you will not see anything 
after you press Enter, as there is no area or line to fill. However, the object still 
exists, albeit consisting of only one or two points. This is referred to as a “dag” 
and should be either deleted or expanded to include at least two points for a 
line and three points for an area.

 Remove or expand all dags.

 WARNING - Dags may corrupt the map data

Move Object to Different Layer

To move an area or line from one layer to a different layer:

 Select the object

 Select Cut from the Edit menu or hit Ctrl 
X
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 Select the new layer

 Select Paste from the Edit menu of hit 
Ctrl C

Note that you cannot move area objects to line 
layers and vice versa - ie can only move an area 
object to another area layer and you can only 
move a line object to another line layer.

Known Area Selection Bug Under Vista

If you are running the MapMaker under Windows Vista OS and using the Aero graphics option, then 
you won’t be able to select area objects. However, if you turn off Aero graphics and use Windows Vista 
Basic graphics instead, it all works fine. To switch graphics under Vista:

 Right Click on the desktop and select Personalisation from the context menu

 Select “Windows Color and Appearance”

 Select “Open classic appearance properties for more options”

 Select “Windows Vista Basic” from the color scheme list and hit OK.

This is a problem outside our control. The problem does not exist under Windows System 7 using Aero 
graphics. 

Crossings

Major River and Lake layers are impassable to all foot and motorised units. Minor Rivers are also 
impassable  to  motorised  units.  They  can  only  be  traversed  at  a  Crossing.  There  are  five  types  of 
crossing, namely a Ferry, Light, Medium and Heavy Road Bridges and a Rail Bridge.

Technically, you can place Crossings anywhere. Each one will produce a crossing point icon when it 
appears in the Game and ScenMaker. Too many produce a cluttered looking map, so restrict their use 
to where they are really needed.
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 IMPORTANT – Once you have drawn your map you must ensure that the crossings actually 
work. To do so:

 Calculate the terrain tables – see Calculate Terrain Tables.

 Select Show Foot Movement Table from the Map menu

 Select Show Motorised Movement Table from the Map menu

The  Movement  Table  opens 
in  small  window,  which  can 
be  expanded  by  dragging  it. 
The white areas represent 
impassable terrain. The darker 
the colour the better the 
movement rate. Thus a Heavy 
Road  bridge  is  a  black  line 
while a light road bridge is a 
light grey coloured line.

 You can reposition and 
resize  the  Movement 
Table window like any 
normal application 
window.

To resize and align the 
movement table window to 
the map window:

 Zoom out the main 
map window so that it 
fits within the screen. 

 Then align the top 
left  of  the  movement 
table window with the 
top left of the map 
window
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 Drag the 
movement table 
window so that 
its bottom right 
is  aligned  to  the 
map window’s 
bottom right. 

This will ensure they 
are  all  at  the  same  scale 
and assist in identifying 
locations.

A valid crossing should 
show a grey or black contiguous 
line from one side of the river to 
the  other.  The  pixels  that  make 
up the line can be diagonally 
adjoining,  but  there  must  be  no 
gaps,  otherwise  the  crossing  is 
invalid.

 Save the map

 Launch the ScenMaker

 Open a scenario using 
the map – see ScenMaker 
Manual for details.

 Use the Route Tool to 
confirm that the Crossing 
is valid – see the 
Confirm Crossing 
section in the ScenMaker 
Manual.
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If  a  route  cannot  cross  the  Crossing  then  you  will  need  to  edit  the  crossing  and  /  or  river  in  the 
MapMaker, remember that there is a 100m movement grid superimposed over the map. When the 
terrain is calculated it ensures that rivers cannot be crossed diagonally. In some cases this may result 
in an adjoining location being classified as river even though the map object does not extend into it. 
This can mean that a river may be blocking an adjoining location, even though it doesn’t appear so on 
the map. 

To ensure the crossing works, try one or more of the following:

 Extend the crossing line on one or both sides or

 Change the angle of the crossing line or

 Reshape the River object by moving its points

Embankments

Any line object ( Road, Rail or River ) can have an embankment or 
cutting added to it. Depending on the value entered, the embankment 
either raises the line above ( e.g. 3m ) or lowers it below ( e.g. –3m ) the 
current spot height. A negative value in effect creates a cutting. A line 
object with an embankment is drawn with a grey line down each side.

 Select a line object

Note that you may have to split the line if you just want to embank a 
segment of it. See – Split Lines / Areas.

 Choose Line Embankment from the Map menu, or press the Enter 

key  (on the main keypad)

 Enter the height of the Embankment in metres (you 
can enter a negative number for a cutting)

 Select OK to close the window

 Press the Enter key  (on the numeric 
keypad) to deselect the line.

The line is now drawn with an Embankment.
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Please note that while embankments affect line of sight, they currently do not inhibit lateral movement 
- ie movement across the line.

Text

To add new Text:

 Select the Text layer displayed in the sidebar

 Select either the Draw or Trace tool.

 Click on the map where you want the new Text to appear

The Text Edit dialog will be displayed

 Enter the text in the Text field

This is what appears on the map. 

To specify the text style parameters:

 Either select one of the predefined styles from 
the Style pull-down menu or 

 specify the individual style components

Font – The font the text will be drawn with.

Style – Select any combination of styles.

Point Size – These drop down lists let you choose the size of the text at each of the six different map 
zoom levels. Setting a size of 0 will stop the text being drawn at that scale.

Whatever settings you specify here will be saved and 
used as the default next time you enter text.

 Select OK  to  save  and  display  your  new 
text.

To edit existing text:

 Select the text to be edited
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 Press the Enter key (on the main keypad)

The text edit window will appear.

 Make your changes

 Select OK.

Select / Deselect Map Objects

To select a map object:

 Select the Arrow tool 

 Select the desired Layer in the 
Layer List

 Click on the object you wish to select

Note that when you select an area object, it’s points are 
displayed with a line linking them and its fill texture is 
not drawn.

If you are unsure of the Layer of the Map / Line you 
wish to select, you can try and locate it like this:

 Choose Multi-Layer Select from the Edit menu

 Click on the desired object

 The first object under the location you clicked will be selected on the map and its 
layer will be selected in the Sidebar as well.

If this is not the object you intended:

 Press the Enter key ( on the numeric key pad )

 Move the cursor slightly 

 Click again
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Another way to identify which layer an object belongs to is:

 Hide  each  layer  in  turn  (  See Show  /  Hide  Layers )  until  the  object  you  want  to  select 
disappears 

When this happens you know the layer you just hid contains the object you want to select.

 Unhide and select the layer containing the object you want to select

 Select the object.

To select all the objects of the current layer:

 Choose Select All from the Edit menu or press Ctrl + A keys  +   

 

To deselect:

 Select a new object, or

 Select a layer from the Layer List on the Sidebar, or

 Press the Enter  (on the numeric key pad) key or

 Select Deselect All from the Edit menu or press Ctrl + D keys  + 

Note that once you deselect an area object its texture fill is redrawn.

Move Map Objects

To move an object:

 Click on the object and drag it to the new location

 Be careful not to select an actual point as this will simply move just that point.
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Prepare Map for Use

Calculate Terrain Tables

Before your map can be used in the ScenMaker, or the Game, it must be 
prepared by having its terrain values calculated. This sets the underlying 
data so the ScenMaker and Game can determine Line of Sight, calculate 
routes and determine movement and hit effects at a given location.

 Choose Calculate Terrain Tables from the Map menu

This may take a minute, 
especially on slow machines. A 
warning window will appear.

 Click OK to proceed.

The MapMaker will then calculate the terrain data for your map. This may take a minute, more on a 
slow machine or if the map is really large.

 IMPORTANT – If you have changed a map then before using it in the Game or ScenMaker you 
MUST Recalculate the Terrain Tables.

Calculating  the  terrain  data  determines  the  terrain  presence  at  each  movement  grid.  From  that  the 
movement and hit effects are derived. It also determines the spot height of each location using the 
distances to the adjoining altitude layers.

Spot Heights

These  are  the  hight  in  metres  at  each  100m  grid  on  the  map. They 
are determined when the terrain tables are calculated. Depending on 
the exact shape of the ground the spot height is calculated using the 
distance to the adjoining altitude layers. As a rough rule of thumb if the 
location is midway between two altitude layers then its spot height will 
be the average of the two ( eg if midway between the 40m and 50m alt 
layers then the spot height will be 45m ).

To display the spot heights:

 Select Show Height Map from the Map menu
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Provided you have already calculated the Terrain Tables, then the Spot Heights window will open. The 
darker the colour, the higher the elevation.

 The Spot Height window can be moved and resized like any normal application window

Check Terrain Data

Unintended Map Islands

After  calculating  the  Terrain  Tables 
you should check for unintended 
map  islands  –  ie  areas  that  are  not 
reachable  from  other  areas  on  the 
map. To do so:

 Choose Show Foot 
Movement Table from 
the Map menu

 Choose Show Motorised 
Movement Table from 
the Map menu

 Click  on  any  grey  area  and 
it and all reachable locations 
will turn blue

This connected area is a map island. Other unreachable areas will remain grey. These belong to one or 
more other map islands. Now this may be exactly what you want, but if not, then you need to consider 
one of the following options to link them:

 Remove  some  of  the  impassable  terrain  (  eg  Woods,  rivers  )  bordering  in  between  the  two 
islands or

 Ensure there is a  valid crossing connecting the two or

 Adjust the altitude layers so that the slope is not too steep

 A slope of greater than 30 degrees is impassable to motorised except where a road traverses the 
terrain.
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 Recalculate the Terrain Tables

 Review again

 Save the map

Intended Map Islands

You should also check to see the intended map islands caused when crossings 
are demolished. You want to ensure that when these crossings are demolished 
areas that should be unreachable actually are unreachable.  To do so:

 Choose Show  Foot  Movement  Table  (  no  crossing  ) 
from the Map menu

 Choose Show Motorised Movement Table ( no crossing 
) from the Map menu

These show the map islands with all crossings demolished.

 Click on each grey area and all reachable areas ( ie parts of the 
same map island ) should be displayed in blue

If this includes areas that you thought should not be part of this island then 
consider one of the following:

 Widening  impassable terrain between the areas ( eg rivers, woods )

 Adjusting the altitude layers to increase the slope between these areas.

 Recalculate the Terrain Tables

 Review again

 Save the map
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Roads and Rivers

If a road line runs too close to a major river, then it may create an unintended crossing. To prevent 
units  from  crossing  major  rivers  at  the  diagonal,  a  special  algorythm  is  run  to  make  the  diagonal 
grids impassable. However, roads will overule this and make them passable. This is fine if the road is 
intending to cross the river eg leading to a crossing. But if the road is running along side the river, then  
you may need to relocate the road further away from the river.
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Generate Map Cache

When  the  Map  is  displayed  in  the  Game,  or  the  ScenMaker,  it  can  be  drawn  using  two  different 
methods.

 On the fly – requires less disk space but is slower

 Using a Cache – faster but requires more disk space

If you wish to increase the drawing performance for your map then you 
must first generate a Map Cache file, this must be done each time you 
change the look of your map - ie add, delete or change the shape of a 
line, area or text object - or the Map displayed will not be the map you 
drew. To do so:

 Select Generate  Map  Draw  Cache   from  the Map 
menu

This can take some time. Large maps can take an hour or more, even longer on slow machines. A 
warning window will appear.

 Click OK to proceed.

A progress dialog will appear while the cache is being created. The map 
cache file will be created in the Maps folder and will be called MyMap.
cop.cache (where your map file is called MyMap.cop).

The size of the map cache file varies from around 2Mb for a small map up to 33Mb for the Olympian 
Passes map.

Once the progress dialog disappears, the map cache will be ready for use.

Save Your Map

It is VERY IMPORTANT that after you have recalculated the terrain and generated the cache that you 
save the map. Otherwise you will lose the changes.

 Save the Map
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Annex A - Keyboard Shortcuts
Left Arrow Select previous point
Right Arrow Select Next point
Backspace Delete
Del Delete

Enter (Num Pad) Deselects the currently selected Area, Line or Text object.

Enter Opens Edit Text dialog for currently selected Text object.

Ctrl + Page Up Zoom Out
Ctrl + Page Down Zoom In
Print Screen copy the current screen to the clipboard

Space (while held down) Activates Grabber tool – left click and drag to scroll map

Alt Reverses the current Point Type while held down

Ctrl-1 to 6 Zoom Map, 1 = 64 meters per pixel, 6 = 2 meters per pixel.

Ctrl + A Select All
Ctrl + D Deselect All
Ctrl + E Display All Layers
Ctrl + G Show Map Grid
Ctrl + H Hide All Layers
Ctrl + L Open Layer Data for currently Selected Layer.
Ctrl + M Open Map Effects window
Ctrl + N New map
Ctrl + O Open map
Ctrl + R Open Map Data window
Ctrl + S Save map

Ctrl + T Toggle Selected Point Type between Corner and Control Points.

Ctrl + U Toggle display of Underlay Bitmap
Ctrl + Y Redo
Ctrl + Z Undo
1     ( Num Pad ) Incrementally move selected point south west
2     ( Num Pad ) Incrementally move selected point south
3     ( Num Pad ) Incrementally move selected point south east
4     ( Num Pad ) Incrementally move selected point west
6     ( Num Pad ) Incrementally move selected point east
7     ( Num Pad ) Incrementally move selected point north west
8     ( Num Pad ) Incrementally move selected point north
9     ( Num Pad ) Incrementally move selected point north east
. Delete

© 2010-2017 Panther Games. All rights reserved. Command Ops is a trademark of Panther Games. All other trademarks and trade names 
are the properties of their respective owners and Panther Games makes no claim thereto.
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Annex B – Map Making Sequence

 Create a New Map

 Update Map and Layer effects

 Rename layers if needed

 Prepare Underlay Bitmap if needed

 Draw Altitude (elevation) layers

 Draw Area (City, Woods, etc) and Line (Road, Rail, etc) layers

 Add Text

 Calculate Movement data

 Verify and Correct any movement problems

 Generate Map Cache

 Save the Map.
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