Command Ops 2 - Core Engine Build 5.1.24 Now Available

Dave 'Arjuna' O'Connor

Panther Games Designer
Joined
Jul 31, 2014
Messages
3,273
Points
83
Location
Canberra, Australia
Website
www.panthergames.com
Command Op 2 Build 5.1.24 is Now Available.

Changes
  • Convert to VS2013
  • Fixed Out of Sync Issue caused by Miquel's code to store entrenchments. Changes to ScenScenario::GetDeploymentState(). Added temp calls to RecordOrVerifyState() to track down the cause inside ScenPlanScheduling::ScheduleNextEvent(), GameEventThread: ProcessPartialMinute(), ScenTaskEvent: ProcessEvent() and ScenDefendEvent: ProcessEventSelf(). Note this fixed the problems inhibiting replaying or recordings and playing a multiplayer game.
  • Fixed possible error inside PGTreeCtrl::Clear(). Now ensures items are removed before clearing.
  • Increased width of Orders dialog to ensure time remaining fields for air strikes are visible.
  • Fixed bug inside PlanAttack::ConfirmTimings() which was eroneously adding an extra minute to the attack duration.
  • Added mIgnoreReinf flag to SMScenarioDataPalette. This allows the user in the sm to specify if a change in the scenario timings applies to the reinforcement schedules.
  • Modified ScenarioData->AdjustScenarioLength() and ScenScenario::AdjustScenarioLength() to facilitate IgnoreReinf changes.
  • Fixed various memory leaks
  • Optimised start process. It now opens around 10% faster,

Note this new build will be installing some new MS redistributable Dlls into your game folder. These are the new VS2013 set and replace the older VS2010 set we have been using. They should also fix the missing ordinal issue that a small number of users experienced. We've tested it here but onlu on a limited set of machine configurations. So we need to monitor this. If you run into any troubles please let us know.
 
Last edited:

James Ling

Member
Joined
Oct 24, 2015
Messages
6
Points
1
Age
57
Location
England
I've installed the patch but cant start the game, I get this message: "the program can't start because mfc120.dll is missing" It advises me to try reinstalling so I downloaded and reinstalled the core engine - but it still wont start and I get the same message.
 

HariSeldon

Member
Joined
Oct 16, 2014
Messages
43
Points
8
Age
66
Location
Florida
I've installed the patch but cant start the game, I get this message: "the program can't start because mfc120.dll is missing" It advises me to try reinstalling so I downloaded and reinstalled the core engine - but it still wont start and I get the same message.

Same problem for me.
 

*budd*

Member
Joined
Oct 20, 2014
Messages
222
Points
18
Age
53
Location
Washington
after the update my game doesn't start. I reinstalled 2013 C++ Redistributable, and rebooted, no dice. I click the shortcut and nothing. When i check task manager, there are 3 co2 exe. processes running, i can't shut them down using end process.
 

TMO

Member
Joined
Oct 21, 2014
Messages
177
Points
18
Age
59
Location
Bristol
Unfortunately I have the same problem. Tried downloading as advised by pierreoza but get an error saying the app won't run on my machine.

Regards

Tim
 

*budd*

Member
Joined
Oct 20, 2014
Messages
222
Points
18
Age
53
Location
Washington
No luck, still not starting. No error messages, just nothing. I look in task manager and there are always 3 instances of CO2exe. running that i cant close out with end process. I uninstalled, cleaned the directories out, checked my .net installation to make sure its up to date and repaired the C++ redistributable. Downloaded the new core engine version and the commanders pack. I installed the core engine and tried to run that before trying the commander pack. No change the core engine doesn't start either and again there are 3 instances of co2 exe. in the process tab. Never had a problem before this update.
 

Dave 'Arjuna' O'Connor

Panther Games Designer
Joined
Jul 31, 2014
Messages
3,273
Points
83
Location
Canberra, Australia
Website
www.panthergames.com
Budd,

What OS are you running? Is your PC a 64bit or 32bit machine? Can you reboot to clear all the old processes and then start up the Task Manager to ensure there is no CO2 process running. Then launch the game and check the processes again for me and report back. Thanks mate. Hang in there we'll get this sorted.
 

*budd*

Member
Joined
Oct 20, 2014
Messages
222
Points
18
Age
53
Location
Washington
Win7 home 64. Rebooted, no instances of CO2 running after reboot. Started CO2 as admin, opened task manager. Game didn't start, 1 instance of CO2 exe running, while i'm watching the process tab 2 more instances of COexe. start up. All using 124kb of memory with no processor activity. I only have the core engine installed at this point. Also cant close any instance using end process, only a reboot clear the processes.
 

Dave 'Arjuna' O'Connor

Panther Games Designer
Joined
Jul 31, 2014
Messages
3,273
Points
83
Location
Canberra, Australia
Website
www.panthergames.com
Budd, send me a DXDiag report please.

Did you install the vcredist package?

I just checked on StackOverflow, which is a community developer site, and it advises that the vcredist version should correspond to the application not the operating system. So I have given wrong advice. My bad and I'm sorry. The correct version of the vcredist package is the vcredist_x86. The vcredist_x64 can be ignoired. Don't worry if you have already installed it. But you do need the vcredist_x86 version unless you already have MS Visual Studio 3013 installed on your machine.
 

*budd*

Member
Joined
Oct 20, 2014
Messages
222
Points
18
Age
53
Location
Washington
i installed vcredistX86, rebooted and tried to run the core engine, nothing. One CO2exe. starts then shortly after 2 more start up. Dxdiag attached.
 

Attachments

  • DxDiag.txt
    29.6 KB · Views: 3

*budd*

Member
Joined
Oct 20, 2014
Messages
222
Points
18
Age
53
Location
Washington
after the update process didn't work i did uninstall and redownload the new build and did a fresh install, want me to try again? the core installer i downloaded today was 118 megs.
 

*budd*

Member
Joined
Oct 20, 2014
Messages
222
Points
18
Age
53
Location
Washington
i uninstalled and cleaned the registry out of any CO2 references. I downloaded the core engine again, its 118megs zipped and 118 megs unzipped. Want me to reinstall or wait on the info from Jason?
 

About LnLP

Welcome to the official Lock 'n Load Publishing Community page. Here you will find the latest information on our released and upcoming games.



We enjoy designing, developing, and publishing some of the best strategy games in the world. Lock 'n Load Publishing has published over eighty products, including our fan favorites Nations at War Series, World at War 85 Series, and Lock 'n Load Tactical series. We have expanded the publishing line now to include novels to go along with our game series in Paperback, EPUB, and Audiobook lines.

As Lock 'n Load Publishing moves forward, it intends to continue to broaden its product lines. We thank God for blessing us and allow us to follow our passions and thank you for support in our endeavors.


Like us on Facebook

Donate Cadence International

Cadence serves all branches of the U.S. military in American and overseas locations. Comprised of nearly 4 million people, the U.S. military community has proven to be one of the largest, most responsive sub-cultures today. Cadence ministers not only to military personnel but to their spouses and dependents as well.

Thank you for your interest in supporting our us. Please specify an amount below to begin the secure, tax-deductable donation process.

Donate to Cadence International
Top