Unable to Update Core Engine

Discussion in 'CO2 - Game Support' started by Pvt. Snuffy, Apr 26, 2019.

  1. Pvt. Snuffy

    Pvt. Snuffy Member

    Joined:
    Apr 26, 2019
    Messages:
    2
    Likes Received:
    0
    I have CO2 Core Engine v5.1.28 and The Cauldron module. I also have downloaded several user-made scenarios. One of those scenarios says I need engine v5.1.31. However, when I try to update it, I get the message that my engine is at the latest release already.

    What am I doing wrong?

    Any help is appreciated.
     
  2. jimcarravallah

    Joined:
    Oct 20, 2014
    Messages:
    629
    Likes Received:
    45
    The 5.1.31 (Beta) update was released on Steam.

    You should be able to get a Steam key for your LnL software to use that Steam utility to update the game.
     
  3. Pvt. Snuffy

    Pvt. Snuffy Member

    Joined:
    Apr 26, 2019
    Messages:
    2
    Likes Received:
    0
    Thank you that answer however, I have the game installed standalone, not on Steam. Was the latest version released on Steam before standalone?

    You mentioned using a Steam utility to update the game, does that also work to update a standalone installation? It doesn’t sound like something that would work, but I really wouldn’t know.
     
  4. ultradave

    ultradave Member

    Joined:
    Apr 24, 2015
    Messages:
    16
    Likes Received:
    2
    You can download the game engine free on Steam, and license your existing DLC on Steam. Then you will have a version with the newer game engine. Won't cost you anything. There are other threads on the forum here that provide directions on how to do that. It's pretty easy to do.
     
  5. j235667

    j235667 Member

    Joined:
    Feb 21, 2019
    Messages:
    6
    Likes Received:
    0
    Thank you very much.

    Do you know why the standalone game isn't at that version? Does LNL Pub. only do their Betas on Steam?
     
  6. Dave 'Arjuna' O'Connor

    Dave 'Arjuna' O'Connor Panther Games Designer

    Joined:
    Jul 31, 2014
    Messages:
    2,908
    Likes Received:
    252
    LNL used to have their own programmer to work up their installer. They no longer do. Once we get this latest build done, we'll see what we can do to provide a solution. I'm sorry for the inconvenience. But it's relatively straight forward to access a Steam version.
     
  7. j235667

    j235667 Member

    Joined:
    Feb 21, 2019
    Messages:
    6
    Likes Received:
    0
    Thank you for the answer. As a new user I just didn't understand your development model.

    I have to say, aside from anything else, I REALLY like the delegation model you use. At least in my training, I learned that 5-7 entities is the most someone can efficiently control under stress. Some of the games want you to control over 50+ units at a time.

    Thank you for the work you and the other debs have done!
     

Share This Page